BlackBerry issues OpenSSL FREAK security note

image
BlackBerry Limited

Following the recent reports of a security vulnerability in OpenSSL, known as FREAK, BlackBerry today issued a security note regarding the vulnerability of BlackBerry devices.

The security note can be found in full at the BlackBerry Knowledge Base but the Overview is included below:

Overview
This security notice addresses the OpenSSL “FREAK” vulnerability that was disclosed on March 3, 2015. BlackBerry® is diligently working to investigate the vulnerability and to determine how best to mitigate customer risk. Investigations are still ongoing, but confirm that BlackBerry products are impacted by this vulnerability. We will update this security notice as new information and fixes become available.

Jon Hunnings

(Step-)father & husband. I code directly on my #BlackBerry devices, in between blogs! Contact me via Twitter: @BrizBerryDevs or via email: brizberrydevs@utbblogs.com

  • razrrob

    Thanks BrizBerryDevs

    This is what sets BlackBerry apart from all the rest, they don’t blame it on the consumer or a vendor or deny it, they announce it, fix it and roll it out. No games, no arrogance

  • Anthony

    Cool locco_smiley_39

  • BB Racer !!

    Efficiently, monitored and Patched….BES was not compromised !

Top